• 3

[OpenWrt OS]18.06 -第一次服務版本發布-August 2018亮麗登場

真的是非常的感謝樓主O大如此熱心的教導.

1.[ 先點Update List ,下面要出現一拖拉庫的Package.....
filter 篩選器裡面打 luci-i18n-base-zh-tw,再點Find Package,右下角點 Install 安裝。] --- 安裝中文成功.

2.8樓所教安裝無線N: 下載Putty 步一步跟著做, 到 [ 砍舊設定檔並重開機讓系統偵測並且產生新設定
# rm -f /etc/config/wireless; reboot ] 這個步驟不成功,跳出已中斷連線警語;由網頁介面重新啟動後; N介面顯示與設定都正常,用手機可連線,不到幾秒鐘就中斷,又重新連線又中斷一直巡迴.

3.這幾天找時間刷回原廠再重刷18.06.1,重頭來過;如再不行就只好認知openWrt不是我這個沒有念書且已65歲的人能使用的.看破刷fork或dd-wrt用吧.

4.不管如何,非常的感謝樓主的分享資訊與熱心地教導,讓小老兒見識了openWrt這麼棒的體驗,但這真是需要有點基礎才能享用阿;感謝樓主~感恩!
RT-N16應該有5年歷史了
若電容爆漿,換什Firmware韌體都一樣

https://www.mobile01.com/topicdetail.php?f=110&t=5233486
ASUS RT-N16連線不穩定更換電容
华硕n16换电容

太難用要換其它firmware,聽了也只是想笑.....要怎選擇是個人心證
OpenWrt起源於 LinkSys 被 Linux組織要求開源而崛起,它的歷史久遠超越15年,
耐得起考驗,UCI命令直譯器更是無可匹敵
全世界的Router OS幾乎都以它為底層基礎架構,然後再自行更改 WebGui界面
不管是Tomoto、Gargoyle石像鬼、DD-WRT、Merlin.......
Linyksys + NetGear跟它更March,不具名網通大廠都是這樣改出來(稻米家族也不例外)
但是OpenWrt更新速度,其他網頁Fimeware、RouterOS幾乎沒人跟得上,Gargoyle搖搖欲墜、Tomoto已死(當然有再出的...)
其它家韌體還再用 Linux Kernel2.6x~ 3.x版時,
改用OpenWrt最新版馬上享受到Linux Kernel(Old Stable) 4.x版本
為什要更換最新 Kernel核心,只有這樣才能避免一堆漏洞
(CPU、RAM、Stack Buffers Overflow....)
2018年分支 LEDE 回流整合完成,2018年下半年開始集聚全球頂尖開發高手,使得更新速度
=====>抗 Hacker駭客能力無與倫比,在CVE漏洞爆出前早就已經出新版了
要當駭客的玩物(網軍的踏板)還是自在悠遊Internet ====> 自己選.....

ps.
# rm -f /etc/config/wireless; reboot 
那是抄自官網,我平常不是這麼下的
(最近OpenWrt Docs有點亂,
八月後突然一堆文章冒進官網,審核機制不夠好,看得眼花撩亂!
什麼舊版 OpenWrt OS 12.x的文章都冒出來!!!!!)
若是我下會是這樣(用 && + 空格 組合指令):
# rm -f /etc/config/wireless && reboot 

omniplay wrote:
官網已經寫的粉清楚了...(恕刪)


請問是不是wireless檔案改變了
因為要刪除的 沒刪乾淨
要裝的 找不到
謝謝
dell wrote:
請問是不是wireless檔案改變了
因為要刪除的 沒刪乾淨
要裝的 找不到
謝謝(恕刪)


有沒有改變 wireless設定,只有你自己清楚,沒圖誰知道呢?
要裝的又是什呢???

用 Putty 登入Router (#是提示你目前使用root權限,不用copy)
rm刪除並reboot重開哪是兩個指令的合併=>組合指令(用 ; 或者 && 組合)
#rm /etc/config/wireless
#reboot -f

組合指令(就是一行搞定)就變
#rm /etc/config/wireless && reboot -f


查找有無->無線網路Wireless設定檔
#ll /etc/config/wireless


不熟UNIX 文字編輯器 vi,用 LUCI(Web)介面設定,
所有Luci設定都會產生相對設應值在 /etc/config/wireless 裡面

直接生成設定檔(免重開)
#rm /etc/config/wireless
#wifi config

Wifi停用Disable
#wifi down

Wifi啟用Enable
#wifi up


用LUCI Web介面進 Network=>Wireless 設定....





omniplay wrote:
有沒有改變 wireless...(恕刪)


移除舊版Driver Module 驅動模組
# opkg remove kmod-b43 kmod-b43legacy kmod-mac80211 kmod-cfg80211 kmod-brcmsmac

安裝新版Driver Module 驅動模組
# opkg install kmod-brcm-wl nas wlc wl

你好

我是想問這兩行的模組
我在luci裡面都沒看見
只找到kmod-mac80211

機器是TP-Link TL-WR1043N/ND v2
openwrt 18.06.1

謝謝






dell wrote:移除舊版Driver...(恕刪)


OpenWrt刷機第一件事是翻開機器屁股HW硬體資訊
https://www.tp-link.com/tw/faq-46.html

TPLINK N跟 ND不一定通用......(ND是台灣銷售版)

第二件事是用Google下關鍵字(Model)查詢Wikidev硬體晶片+版本號(v1.v2.v3.v4........v13)

你應該搞錯了吧?! 誰告訴你--->不同機型、不同晶片之間設定可以互用?
高通Qualcom用的是高通的驅動(kmod-ath、kmod-ath9k、kmod-ath9k-common)
博通Broacom用的是博通的驅動(kmod-brcmsmac、kmod-brcmsmac....)
掛對正確的晶片驅動 ,才會讓Wireless無線網路運作正常!



不同機型的掛載的驅動軟體當然不同,別拿給樓上ASUS RT-N16的設定法套在 TPLINK WR1043ND

幫你找好了 Google搜尋關鍵字
TL-WR1043ND v2 刷機

OpenWrt官方韌體 ,刷完先把它原始的設定(Lan、Wan、Wireless),
好好熟練界面,上網沒問題,剩下的再說

重點是:你沒事搞那個驅動 弄哪些要幹嘛?(先搞清自己的目的地)

如果設壞了想重來回復OpenWrt原始值


Wireless也粉簡單(看是要Remove移除還是Add新增),錯了就Remove重來

omniplay wrote:
OpenWrt刷機第...(恕刪)


感謝
一下就抓到我的盲點
想問一下
我目前想裝openwrt x86_64
上個官網後發現lede跟openwrt在合併了
會想裝openwrt或lede主要是看到它的外掛很多

我知道lede的跟openwrt只是分枝,目前合併中,看官網應該是合併完了

想問
1.有沒有網站是在介紹openwrt他的package,或是有package list的地方,想知道openwrt有哪些package
2.雖然lede已經與openwrt合併了,但我看到lede還是有在持續更新,兩者的package可以互用嗎?

感謝大大的協助

發完文章後就發現自己鬼遮眼,package list找到了..
只是還沒找到lede的package跟openwrt的package有沒有不同就是了
電腦一(WorkStation) cpu:i7-3820 RAM:16G(DDR3) mb:p9x79 gpu:AX6670 HDD:SSD128G+
j90s5520 wrote:想問一下我目前想裝openwrt...(恕刪)

這帖就是答案 [OpenWrt][Security]CVE-2018-17182 UAF+PoC 漏洞修補
看過這帖還會想用舊版LEDE FW?

1.1、相關網路安全Policy: Firmware韌體、軟體 ,一概用新不用舊!
除非新版有問題才會降一版,甚至降到沒問題哪版,

1.2、但新版Snapshot 出槌的機率對OpenWrt來說機率太小:
 它有BuildBot開發AI機器人每次批次產製一千多台的韌體
-用量子電腦?一個公益性社群或許不太可能有這種財力,
我也挺好奇它是如何做到的?(當然他們也不是100%,還是會有某些Model會出槌)

1.3、版本問題I-不同的Kernel有不同版本的Library ,
舊版FW用新版的Package可不可行???
當然不建議 ,雖然我幹過這種事 ,
官方打包好的粉多問題處理就在編譯過程中解決掉了!
一般Router FW只要sysupgrade就行了,
至於x86_64就是下載新的image重新轉檔

1.4、版本問題II - OpenWrt是由Debain port移植過去的
它所有的版本號幾乎跟Debain版本號同步-
OpenWrt Kerenl-4.14 相對於Debain Testing版本
(介於Stable穩定版4.9 Unstable SID 4.18之間)
至於為什只到4.14?雖然我也知道4.18可以更新更多硬體
但因為FOSS Linux 公益團隊的硬體HW-Firmware就只支援到4.14
不然你去幫忙寫???
這已經比其他RouterOS的版本號高了粉多 ,
e.g DD-WRT進化到4.4 ,Qualcom的QSDK也是4.4,
Broadcom的SDK聽說也才3.x

玩轉Openwrt Package-就像劉姥姥進大觀園(淺嘗是粉難透析的)
---因為版面TOC分類不夠好 ,不然你去幫忙更新版面阿?

玩法1:Luci更新Update List -英文字母A-Z全逛完
不太建議用Luci查詢特定package-因為它不會告訴你是否已安裝!

玩法2:利用官方糟糕的淺級分類表-Package Index,或者用關鍵字查詢Package Table

玩法3(這招官網都有寫了!):SSH登入,Opkg Package Manager 指令- opkg
就看你對opkg指令有多熟?opkg 永遠的起式第一式 # opkg update
常用指令
# opkg list-installed     //查詢所有已安裝package
# opkg list-installed |grep {packagename}  //查詢特定package
e.g # opkg list-installed |grep luci
# opkg find luci        //會列出版本號、Package用途重點內容...
# opkg info luci        //會列出Dependency依賴的library/副package、安裝狀況...
.............................
官方沒告訴你的事
1.可以用萬用字元* 加在Package關鍵字- 前墜 或者 尾墜 ,可以前後都加*
e.g  kmod-*
e.g *18n*

2.Package檔名『-』 跟 『_ 』 的差異,可以用*的是『-
_ 』後面的字根本不用鳥它,那是註明版本號而已,除非有新版本號發布。

3. https://downloads.openwrt.org/
Target(FW韌體)裡面還有Package 套件,
大部分是比較重要以掛入核心Kernel中以kmod開頭為主的硬體HW-Firmware Package套件
(Openwrt Hardware Driver多以firmware為名,跟Debian Linux通用通名)
--------------------------------------------------------------------------------------
中階的玩法:會跟莊
可以自行打造Developer開發環境, 自行解決OS 開發穩定性
可以完整複製 git clone OpenWrt的git
可以獨立自產FW韌體/Package-ipk不求人, 自己解決Dependency的問題。
---------------------------------------------------------------------------------------
進階高級的玩法:須要會寫OpenWrt特定格式的Makefile
(跟其他Linux OS的格式完全不同的, 不能拿來套用)
然後自行Make Compile編譯 - 可以自製ipk檔案
然後加入社群與全球高手交流, Bug Feedback 或者改造原始碼軟體-改出ipk供別人使用
omniplay wrote:
這帖就是答案 [OpenWrt...(恕刪)


容小弟弱弱的問一個
package不論是在網頁上安裝
或是在ssh上安裝
是不是在網頁上面都不會有相關的超作
都要用cmd去做

另外最近是剛好有一台電腦
g1620已經很久沒用了
加上硬路由怪怪的
想說來試試看
原本的硬路由是ddwrt
現在想來玩玩看openwrt
果然複雜度立馬提升哈哈
電腦一(WorkStation) cpu:i7-3820 RAM:16G(DDR3) mb:p9x79 gpu:AX6670 HDD:SSD128G+
  • 3
限制級
您即將進入之討論頁 需滿18歲 方可瀏覽。
根據「電腦網路內容分級處理辦法」修正條文第六條第三款規定,已於該限制級網頁,依台灣網站分級推廣基金會規定作標示。
評分
複製連結