MikroTik RouterOS Hotspot

Difficulty: ★★★☆☆
Version: RouterOS v6.24

什麼是Hotspot?
各位一定有印象,當您使用公眾WiFi的時候,連接WiFi SSID不用密碼即可連上,但隨即會跳出一個網頁,請您輸入帳號密碼(e.g. CHT HiNet),或不用輸入帳號密碼但需點選同意上述規範(HongKong Airport)。不論連接WiFi SSID是否要輸入密碼,只要連接上WiFi後會跳出一個網頁請您先進行下一步動作,然後才能進入Intranet或Internet的程序,就是Hotspot。

Hotspot的角色
裝置要能連上網路(區網或外網),有三個階段:
.第一階:無線(帳號及密碼、或無)或有線連接至設備
.第二階:Hotspot進行認證,通過後正式進入設備(路由器)
.第三階:設備(路由器)內部通過Intranet與區網連接或通過Internet與外網連接

使否要讓裝置進入設備(路由器)?除了可以用鎖定MAC address的方式外,也可以用Hotspot進行帳密認證

.鎖MAC address:裝置導向,只有登錄過的裝置可以上網
.Hotspot帳密認證:使用者導向,只要有正確登錄的帳密則可上網

使用方向不同,各有利弊,我們今天只講述有關Hotspot的設定與延伸

如何設定Hotspot?
有關Hotspot的詳細說明,可以參考MikroTik Hotspot

1. 要能使用Hotspot,需要先安裝Hotspot這個package,檔案可自MikroTik官網下載
/system package enable hotspot
重新啟動後可以在磁碟上看到hotspot這個資料夾
2.設定Hotspot有兩種方式,一是透過內部的setup命令來step-by-step設定,簡單好上手,輸入完就可以使用了。
/ip hotspot setup
也可以自行手動根據以下步驟來設定
/ip pool
add name=DHCP ranges=192.168.2.32-192.168.2.63

/ip hotspot profile
add hotspot-address=192.168.2.1 name=HS_Prof

/ip hotspot
add address-pool=DHCP interface=LAN name=HotSpot profile=HS_Prof

/ip hotspot user
add name=Test-User password=pass1234

其中「LAN」這個interfacec後所接的任何設備,不管有線、無線,要連接上網前都會出現以下畫面
MikroTik RouterOS Hotspot
輸入使用者帳號「Test-User」及密碼「pass1234」後登入,畫面呈現連線狀態
MikroTik RouterOS Hotspot
而當你登出後,畫面會顯示統計資料
MikroTik RouterOS Hotspot
Hotspot的應用
基本上,Hotspot的設定可以說是非常容易,幾個步驟就完成了。MikroTik RouterOS所提供的Hotspot功能,也是當初我推薦從事餐廳業的朋友換用RouterOS一個重要的因素。原先他的餐廳就有提供消費者免費無線上網的服務,跟一般公眾場所一樣,有一個要輸入密碼的SSID,後來有其他業者到他的餐廳推銷另一種服務,主要更動是改成免輸入WiFi密碼,但連線上後會先看到該業者提供的其他商家廣告,點選下一步後則可順利上網。優點或許是消費者不用一直向員工詢問無線密碼,缺點是每當消費者第一次連接上網時就會看到其他商家的廣告,並且該服務每個月都要付費。我們這邊不討論該服務的商業模式。

透過採用RouterOS的Hotspot功能,我們做了一些小修改:
1. 取消使用者帳密機制,開啟Hotspot的中的Trial登入,登入畫面中使用者只要點選確認即可上網
2. 修改hotspot資料夾中的檔案,改變登入畫面,並加入使用者上網規範。這樣一來就跟我們在例如香港機場使用WiFi那樣,有一整列的規範,同意後即可上網。

hotspot資料夾
有關hotspot這個資料夾裡面的每個檔案說明,可以參考MikroTik Hotspot Customization,這裡我分享一下「login.html」中如何使用Trial登入
<button type="button" onclick="location.href='$(link-login-only)?dst=$(link-orig-esc)&username=T-$(mac-esc)';">接受(Accept)</button>

<button type="button" onclick="window.close();">拒絕(Deny)</button>

以及登入後,除出現原先欲連結網址的網頁外,如何再帶入另一個網站。這裡我分享一下「alogin.html」中使用的程式片段。單書名號刻意相反使用,否則無法正常於Mobile01文章中顯示。
>script language="JavaScript"<
>!--
function startClock() {
..........
open('http://www.mikrotik.com/', 'MikroTik','');
..........
}
//--<
>/script<

幾個檔案經過適度的修改後,所呈現出來的網頁就相當美觀,而餐廳內的消費者只要按下「接受(Accept)」上述使用者規範後,除原先欲連結網址的網頁會順利出現外,還會再多開一個該餐廳的首頁。

後記
過去如果我們需要這種類似的上網認證功能,往往需要採用少數特定的路由器設備,或甚至多掛一台設備,如今透過MikroTik RouterOS的Hotspot功能,簡單的實現了一機多功。

延伸閱讀
[開箱] MikroTik CCR1016-12G
MikroTik RouterOS VPN (PPTP/L2TP/OpenVPN/SSTP/SSH Tunnel)
MikroTik RouterOS Stateless Tunnel (EoIP/IPIP/GRE)
MikroTik RouterOS QoS (Queue/HTB/PCQ)
MikroTik RouterOS IGMP Proxy w/ CHT MOD
MikroTik RouterOS Hairpin NAT - Pros & Cons
MikroTik RouterOS User Manager - RADIUS
MikroTik RouterOS Load Balancing - Pros & Cons
2014-12-27 13:52 發佈
想請教有沒有大大會做hotspot帳戶到期前提醒和到期停用?

Mason.Lyu wrote:
Difficulty...(恕刪)

Mason.Lyu wrote:
Difficulty...(恕刪)


宿網只讓獲允許的用戶使用. 可以控制某些用戶利用Hotspot方式輸入帳號密碼方式使用網路, 且同時某些用戶則無需使用帳號密碼使用網路嗎? 因為不是所有聯網裝置都可以輸入帳號密碼? 如機上盒則無法輸入帳號密碼, 應該如何控管用戶使用? 用MAC鎖定嗎?

Sabrina111185 wrote:
宿網只讓獲允許的用...(恕刪)


預先放行指定的MAC.
http://wiki.mikrotik.com/wiki/Manual:IP/Hotspot#IP_Bindings

Mason.Lyu wrote:
Difficulty...(恕刪)


請問我用PC可以看到彈出視窗,但是用手機,已經確定允許顯示彈出視窗了,但是卻不顯示的原因為何?

還有,若不小心關閉了彈出視窗,如何能再叫出來?
fgtsai0418 wrote:
請問我用PC可以看到(恕刪)



我也遇到相同的問題, 請問有解決方法嗎? 謝謝.
評分
複製連結
Mobile01提醒您
您目前瀏覽的是行動版網頁
是否切換到電腦版網頁呢?
' + '