• 746

[研究所] MikroTik RouterOS 學習 (持續更新)

gfx wrote:
其它VPN over PPPoE最佳MTU各為:
PPTP=1400 / L2TP=1452 / SSTP=1400 / OVPN=1500



我台灣家裡是接中華光世代固定制,ONU過來直接是走乙太網 TCP/IP
所以 1500(Ethernet) -20(IP_HEADER) -20(TCP_HEADER) = 1460 就是 L2TP 的最大 MTU 值。


我在日本接的NTT東日本光回線,是用 PPPoE 撥接的關係,
聽說是終端內部走 L2TP 的關係,所以 MTU 被限縮到 1454
所以 1454(PPPoE) -6(PPPoE_SESSION) -2(PPP_HEADER) -20(IP_HEADER) -20(TCP_HEADER) = 1406
雖然光回線規格是上下1Gbps,但是感覺真的小好多啊!
請教各位

Mikrotik 的SFP+ 模組 是否要專用的款式?
坊間通用的SFP+ 可以使用嗎?
Allen Yeh Škoda Fans Club http://fans.skoda.club.tw/
lenbo wrote:
因為腳本是排程一小時(恕刪)
pptp|l2tp|ike2用戶端地址腳本,需整點開始,每分鐘run一次:
:local date [/system clock get date]
:local tt [/system clock get time]
 
:local month [:toarray "0,jan,feb,mar,apr,may,jun,jul,aug,sep,oct,nov,dec"]
:local mm [:find $month [:pick $date 0 3]]
 
:local cli
:foreach i in=[/log find topics~"(pptp|l2tp|ipsec)"] do={
 :local content [/log get $i message]
 :local conform no
 :local dd [:pick $date 4 6]
 :local t [/log get $i time]
 
 :set conform ([:pick $t 0]~"[012]" && $t>=$tt-0:1:0)
 
 :if ([:pick $tt 0 5]="00:00" && [:pick $t 7 12]="23:59") do={
  :local m [:find $month [:pick $t 0 3]]
  :local d [:pick $t 4 6]
 
  :set conform ($mm=$m && ($dd-$d)=1)
 
  :if ($dd="01" && (($mm-$m)=-1 || ($mm-$m)=-11)) do={
   :set conform ($conform || ($d=30 && [:find 4,6,9,11 $m]>=0))
   :set conform ($conform || ($d=31 && [:find 1,3,5,7,8,10,12 $m]>=0))
   :set conform ($conform || ($m=2 && [:find 28,29 $d]>=0))
  }
 }
 :if ($conform) do={
  :if ($content~"from") do={
   :set cli [:pick $content ([:find $content "from"]+5) [:len $content]]
  }
  :if ($content~"ike2") do={
   :local ed 0 ; :local count 0
   :do {
    :if ([:pick $content $ed]="[") do={:set count ($count+1)}
    :set ed ($ed+1)
   } while=($count<2)
   :set cli [:pick $content ([:find $content "-"]+1) ($ed-1)]
  }
  :set cli [:toarray "$t,$cli"]
 }
 :if ($content~"( connected|acquired)" && [:pick $cli 0]=$t) do={
  :do {/ip firewall address-list add list=VpnClient address=[:pick $cli 1] timeout=1d} on-error={}
 }
}
 
腳本只會抓目前時刻,前一分鐘內所連線進來的地址,避免過去已離線的用戶被登記。
但前一分鐘若是牽扯到跨日/跨月/跨年...很不容易啊。
allen_yeh wrote:
請教各位Mikrotik...(恕刪)


應該大部份vendor sfp+都能兼容,我用ubnt sfp+的
請問一下FTP的設定
我用FileZilla Server Interface
用ftp://192.168.88.254能成功
但用外網IP就連不上了
防火牆有測試通過
FTP的教學文好像不多,我都沒弄成功..
 
外網(210.6.xxx.133) > Mikrotik RouterOS > HUB > 電腦(192.168.88.254)
IP > Address Lisrt裡面是
 
address: 210.6.xxx.133/26
network: 210.6.xxx.128
inferface: ether1
 
address: 192.168.88.1/24
network: 192.168.88.0
inferface: ether2
gpman2020 wrote:
請問一下FTP的設定(恕刪)
FTP由於發展的比較早,
當時網際網路還未發展,未曾考慮防火牆NAT。

也就是FTP在內網使用,不透過NAT到網際網路都很好用;

但只要經過NAT就是個大麻煩,Port Forward不只在伺服端上需設置,
連客戶端也要設Port Forward...簡直是個災難!!

請先確認您架設的FTP是主動模式(PORT Mode)及被動模式(PASV Mode)
http://n.sfs.tw/content/index/10303
再確認問題是否在本地。
寶貝:)開心最重要.嘻哈!
話說,沒有重大安全性或BUG修正的話,實在拿不準什麼時候才該升級 RouterOS 啊!
lenbo wrote:
話說,沒有重大安全性(恕刪)
6.47是重大更新,支援DNS轉發與DOH。

DNS轉發即可指定特定網址,經非預設的DNS伺服器對進行查詢。

DOH即連接DNS伺服器,不用預設未加密的UDP Port:53進行連接;
而是透過加密的https(TCP Port:443),使用憑證進行連結。
我是使用Hinet IPv6 Dual Stack,請問最近有人遇到IPv6在dhcp-client這邊狀態一直是searching無法變成正常bound抓到prefix

設定IPv6之前有正常使用超過一年以上,最近發現client都沒有被分配到IPv6上來查才發現問題在於dhcp-client這邊狀態一直是searching,所以導致分配不出來,以下是我的設定,我也參考了不同的配置進行調整但問題還是無法排除。

1. 我嘗試用Windows 10撥號或是I-040GW的硬體撥號都是正常可以拿到IPv6地址。
2. 目前韌體已經更新到6.47問題依舊
3. 嘗試使用不同的port也還是無法取得IPv6 prefix

從另一個討論也看到最後一個回覆也是同樣的問題
https://www.mobile01.com/topicdetail.php?f=110&t=3195673&p=3&p=3#69105429


/ipv6 dhcp-server
add address-pool=Hinet_IPv6 dhcp-option="" disabled=no interface=bridge-local \
lease-time=3d name=DHCPv6_Server preference=255 rapid-commit=yes \
route-distance=1 use-radius=no
/ipv6 address
# address pool error: pool not found: Hinet_IPv6 (4)
add address=::1/64 advertise=yes disabled=no eui-64=no from-pool=Hinet_IPv6 \
interface=bridge-local no-dad=no
/ipv6 dhcp-client
add add-default-route=yes default-route-distance=1 dhcp-options="" disabled=\
no interface=HinetPPPoE pool-name=Hinet_IPv6 pool-prefix-length=64 \
prefix-hint=::/0 rapid-commit=no request=prefix use-peer-dns=no
/ipv6 firewall address-list
add address=fe80::/16 disabled=no dynamic=no list=allowed
add address=ff02::/16 comment=multicast disabled=no dynamic=no list=allowed
/ipv6 firewall mangle
add action=change-mss chain=forward comment=ChangeMSS !connection-by
!connection-limit !connection-mark !connection-rate !connection-
!connection-type !content disabled=no !dscp !dst-address \
!dst-address-list !dst-limit !dst-port !headers !hop-limit !icmp
!in-bridge-port !in-bridge-port-list !in-interface !in-interface
!ingress-priority !ipsec-policy !limit log-prefix="" new-mss=\
clamp-to-pmtu !nth !out-bridge-port !out-bridge-port-list !out-i
!out-interface-list !packet-mark !packet-size passthrough=yes \
!per-connection-classifier !port !priority protocol=tcp !random
!src-address !src-address-list !src-mac-address !src-port tcp-fl
!tcp-mss !time !tls-host
/ipv6 nd
set [ find default=yes ] advertise-dns=no advertise-mac-address=yes
no hop-limit=64 interface=bridge-local managed-address-configura
mtu=unspecified other-configuration=yes ra-delay=3s ra-interval=
ra-lifetime=30m reachable-time=unspecified retransmit-interval=\
unspecified
/ipv6 nd prefix default
set autonomous=no preferred-lifetime=1w valid-lifetime=4w2d
/ipv6 settings
set accept-redirects=yes-if-forwarding-disabled accept-router-advert
yes-if-forwarding-disabled forward=yes max-neighbor-entries=1024

  • 746
評分
複製連結
請輸入您要前往的頁數(1 ~ 746)